The forums are being retired in favor of a new help portal with improved knowlege base and direct access to support. - Please visit our new help portal for information and support.

Autofile domain/emai rules wont work for particular messages

Have a support question regarding ClearContext for Microsoft Outlook? Find help here. Be sure to include what version of Outlook and Windows you are using.

Moderator: ClearContext Support

Autofile domain/emai rules wont work for particular messages

Postby jreyes » Wed Feb 02, 2011 7:06 am

This may have be something you are working on but in the preview 5.3 version i have a problem with autofile custom rules not working with particular domains/email addresses while if i create autoassign rules using domains/email addressed autoassign rules do work -- believe the problem is that a different algorithm is being used by autoassign/autofile to parse the email address/domains .

What is interesting is that the autoassign for the message does work very well but the autofile doesn't know what to do with the message.

Here is an example.

Have a BACN daily newsletter message that is listed coming from:

yourinspiration@aweber.com on behalf of Audri and Jim Lanford [yourinspiration@famous-quotes-quotations.com]

Now if i create an autoassign rule, my email/domain choices are
yourinspiration@aweber.com or all messages from @aweber.com

this works fine, the autoassign works correctly and assigns the correct topic i want

BUT

when i try to create an autofile rule,
the email/domain choices are
yourinspiration@famous-quotes-quotations.com or all messages from famous-quotes-quotations.com

this rule will never move this message from the inbox to the autofiled BACN


there are other examples of newletters primarily where BACN newletters are using some service like aweber.com or constant contact to send their email newsletters.

believe the problem is autoassign is correctly using the remailer address for choice while autofile is using the original senders email address.


i have other examples if you are interested.

kind regards

J
jreyes
 
Posts: 18
Joined: Fri Mar 03, 2006 7:14 am

Re: Autofile domain/emai rules wont work for particular messages

Postby ClearContext Support » Wed Feb 02, 2011 1:50 pm

when i try to create an autofile rule,
the email/domain choices are
yourinspiration@famous-quotes-quotations.com or all messages from famous-quotes-quotations.com

this rule will never move this message from the inbox to the autofiled BACN


Did you create the rule and validate that messages weren't moved? Though the choices look different, I expect this AutoFile rule to handle this sender correctly.
ClearContext Support
 
Posts: 3646
Joined: Wed Jan 09, 2008 1:52 pm

Re: Autofile domain/emai rules wont work for particular messages

Postby jreyes » Wed Feb 02, 2011 3:05 pm

Yes i Checked that the messages weren't moved

the offending messages using a remailer stay in the inbox, -- if i highlight it and autofile it it will move of course, but it won't automatically get filed when it moves into the inbox nor will it move when i go to options>autofile>apply to inbox.

there is a rule for it in the custom autofile rules but doesn't matter.

it stays in the inbox.
jreyes
 
Posts: 18
Joined: Fri Mar 03, 2006 7:14 am

Re: Autofile domain/emai rules wont work for particular messages

Postby ClearContext Support » Wed Feb 02, 2011 9:57 pm

Please verify that there isn't an AutoFile rule that is acting on the message. AutoAssign rules take precedence over AutoFile rules.
ClearContext Support
 
Posts: 3646
Joined: Wed Jan 09, 2008 1:52 pm

Re: Autofile domain/emai rules wont work for particular messages

Postby jreyes » Mon Feb 07, 2011 2:15 pm

understand that autoassign take precedence.

nope, if i delete any autoassign rules that might impact this message, autofile doesn't file it away in autofile bacn subfolders-- it stays in the inbox -- it' doesn't seem to like the domains

For example here is another email address header that isn't autofiling --

From: sfsweeklynews@aweber.com [mailto:sfsweeklynews@aweber.com]
On Behalf Of Off The Grid News (info@offthegridnews.com)


if i create an auto assign rule -- it will provide choices of "sfsweeknews@aweber.com" or "@aweber.com" as email address and domain -- it will file correctly to a project file

but if i delete the auto assign rule and then create an autofile rule, the choices it gives me are
info@offthegridnews.com or @offthegridnews.com

this won't autofile to the BACN autofiled subfolders-- it will stay in the inbox - even if i try to use the"apply to inbox" button in the clearcontext/options/autofile dialogue box, -- it won't autofile


note that if i reply to the above email address the "replyto" address is:
Off The Grid News(info@offthegridnews)

would seem that if autofile usese the same algorithm for determining the domain/email address ass auto assign does that this would fix the problem --

not sure why different methods are used int autofile and autoassign for determining the domain/email address but that seems to be the only difference that creates the problem.

hope this helps
jreyes
 
Posts: 18
Joined: Fri Mar 03, 2006 7:14 am

Re: Autofile domain/emai rules wont work for particular messages

Postby brad » Mon Feb 07, 2011 4:46 pm

Jesse:

In the case you describe, the rule should work as expected. Please go to ClearContext > About > Email Support and send us the data in that email along with a message you are seeing this problem with. Drag the affected message onto the support email to attach it. Thanks.
Brad Meador
brad
 
Posts: 2161
Joined: Wed Jun 16, 2004 5:35 pm


Return to ClearContext Professional Features & Support

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 1 guest

cron